Maestro 6-Channel Red & Yellow LED blinking after connection


I had got everything working for a while with the Maestro Control Center.
After some test on the servo limits, the controller started to fail on me.
The servo power was connected to Micro Maestro’s +5 V (Out ).
I restarted the PC and re-plugging the usb, the device manager could not detect the device properly and gave me an usb error code 43.
Once i plugged in, the green and yellow leds blinks for awhile before flashing both red,together with yellow leds periodically.
I’m using Windows 7 , 32bit. Had re-installed the drivers using setup.exe. Still the same results.

I couldn’t find a similar description in the manual.
Did i just fried my controller?


The 5V (out) pin (and USB in general) does not have enough current for even a single servo, and attempting to power a servo with that output could damage your Maestro or even the USB port. Could you verify that the LED blinking you describe is still happening with nothing except the PC (no servos!) plugged into the Maestro?


Well after that happened, i did remove the connections from +5v(out) to servo power.Servos removed as well.
It behaved the same, no valid device detection.
I was using a small Turnigy TG9e servo.

some times, i rarely have a valid hardware detection. Once i had, i tried Control Center and it gave me this message :slight_smile:


So every time you plug it in, green and yellow blink for a while and then red and yellow blink together? Do they blink evenly or is there some other pattern? Have you tried other USB ports?


ok, this morning i tried again, it works fine for a while until i re-plug-in.

I guess it needs some rest time. When i try again by an hour, it at least gave me valid detection but no control.
This gives me green and yellow blinking leds for awhile, followed by error code 43.

When the usb gives me error code 43, the pattern of the red & yellow leds are quite random, sometimes it gives a short bursts of blinks. Both blinks together, also no green led… Quite like the way Harddisk indicator blinks but it do not affect the controller leds.

I have tried other USB ports and with another computer. same results.

anyway thanks for attending the problem!