Maestro 12-channel servo controller - Can't reach target


We have been using the servo controller to control 8 servos. We ran the servos to set positions while varying the speed and acceleration limit setting (5-255 for both, incrementing by 5).
At specific combinations of speed and acceleration settings, the servo could not reach the set position and just jerked back and forth around the target. The following table lists the specific range combinations of speed/acc settings which don’t allow the servo to reach its target.

Speed Incompatible Accelerations
20 40-50
25 50-78
45 90-112
50 100-255
55 110-168
70 140-175
100 200-255
120 240-255
125 250-255

We also have the problem at faster speeds where the servo will jerk close to the set position, but still reach the target.
Actions to try and resolve the issue:

  • using alternative servos
  • changing servos around
  • not powering the servos (observing through Status window in Maestro Control Centre)
  • removed servos altogether (observing through Status window)
    None of this worked.

Another thing we tried was to extend the Min-Max range in Channel Settings. This resolved the issue for the specific speed/acc combinations listed above, however it introduced a new range of combinations which are incompatible.

We want to be able to use the full range of speed and acceleration combinations for ease of coding.
Any suggestions on how we can resolve this issue?


Thank you for listing all of that information. I tried the speed and acceleration values you have listed (with and without a servo connected), but did not see the behavior your describe. What firmware version does your Maestro have? You can find the firmware version by connecting your Maestro to your computer via USB and opening the Maestro Control Center; the firmware version should be displayed in the upper left corner next to the “Connected to” drop-down box. If you do not have the most recent firmware (1.02), can you try upgrading to the latest version by following the steps in the “Upgrading Firmware” section of the Maestro user’s guide?

If you have the latest firmware version and are still seeing the same behavior, can you configure the channel settings in a way that displays the problem and post your settings file? You can save your settings file by using the “Save settings file…” option in the “File” drop-down menu within the Maestro Control Center.