Maestro 12 Channel Problems

I have a 12 channel Maestro and it is connected to a PC via the USB port.
It shows up in the device manager and the lights on it come on and blink when attached to the computer.
I have 6 servos attached to it and each one of the servos is brand new (MG-995 Servo).
I am using a 3.7 volt lithium battery pack to drive the servos.
I am using VB to control the servo, below is a sample code from one channel I use.


If MSComm1.PortOpen = True Then             
        MSComm1.PortOpen = False                
        MSComm1.Settings = "9600,N,8,1" 
        MSComm1.CommPort = 10                   
        MSComm1.OutBufferCount = 0
        MSComm1.PortOpen = True                 
        MSComm1.Settings = "9600,N,8,1" 
        MSComm1.CommPort = 10                    
        MSComm1.OutBufferCount = 0
        MSComm1.PortOpen = True                 
    End If


If MSComm1.PortOpen = False Then
MSComm1.PortOpen = True
End If
        MSComm1.Output = Chr$(255) 'Synchronisation
        MSComm1.Output = Chr$(0)  'Select Servo 0
        MSComm1.Output = Chr$(VScroll1.Value) 'Set Servo Position this value comes from the slider.value
        'MSComm1.Output = Chr$(85) 'Update
        MSComm1.OutBufferCount = 0 'Clear Buffer
        MSComm1.PortOpen = False

What happens is this, it will work great for awhile and then for no reason will stop responding to anything even the Pololu Maestro Control Center.
The comm port on the Maestro is set to 10 and nothing changes.
The lights on the board are still blinking and the device is still shown in the device manager.
I have three battery packs all the same 3.7volts and I have tried each one on it and the same results.
I can let it sit for a couple hours and then it will start to work again.
Meaning I shut the computer off and disconnect the battery from the Maestro 12 channel.
After a couple of hours it will work again for about 10 minutes and then the same things starts again.
I have tried a different USB cable and this makes no change, I have tried a different computer and this makes no change.
What can cause this, is there a fix for it?
Thank you


It sounds like you might be having a power issue. Do you lose USB connection to the Maestro when the servo stops moving? If you do not, your battery is probably unable to supply enough power to the servos, and you might try using a battery with a higher nominal voltage or capacity. If you are losing USB connection, you might be getting noise on the USB port. Some ways to help with USB port noise are to add or get a USB cable with ferrite beads, or use a powered USB hub between the Maestro and computer.

- Grant

Based on your reply I tried the following lastnight.
Power Source: 6V Nicad Pack
Standard USB cable
Once again the unit functioned correctly for a period of time and then without and reason it just stops responding.
I checked the Device Manager and both ports are still showing up and nothing changes as I refreshed the device manager a few times.
I then checked the power source (Battery Pack) for Voltage and I am showing 5.8 Volts.
I let it sit for about an hour maybe shortly longer and tried it again and it worked.
So I then tried it out on another computer using the same software and had the same thing happen after about 12 minutes of use.
Repeated the process again by checking battery power and it had dropped slightly to 5.6 Volts.
This is really getting on my nerves and I have tried to do process of elimination to rule out any thing that could be causing a problem.
I even went to the extent of removing software from the computer that runs on startup as it might cause some issues and nothing has helped.

It isn’t clear to me why you are waiting an hour before trying the Maestro again when it freezes. Is there a specific reason you are waiting that long? You should be able to get it working again right away by disconnecting the USB cable, closing all programs using the Maestro, and then reconnecting the Maestro.

It still sounds like the issue might be from electrical noise in the system interfering with USB operation. Can you try some of the things I suggested in my last post (using a USB cable with ferrite beads or a powered USB hub) and see if the problem persists?

- Grant

I do not know why I have to wait so long before the Maestro will work again.
I have tried to disconnect everything and then hook it back up right away and it does not work.
I have waiting a few minutes to several and it does not work.
This is why I am writing in to you guys in hopes of figuring out why.
If you look at my previous post you will find that I have tried to use another computer and this does not make a difference.
I have tried to use another USB cable and this did not make a difference.
I have tried a different power source and this does not make a difference.
Last night I tried yet another computer and this time I only attached 2 servos, one on channel 0 and one on channel 6 and used the Pololu control software.
I set up a simple script for it to turn the servos back and forth and set it to loop.
It ran for about 11 minutes and then became unresponsive.
I shut the computer down and disconnected the USB cable and the power source.
I restarted the computer and then connected the USB cable to the computer then attached the power.
Tried to run it again and it would not do anything.
Checked the ports under device manager and they are showing up.
Its like it has a mind of its own.
Once again I waited about 10 minutes and tried again and still no luck.
I then let it sit for about a hour and then it worked again for about 12 minutes and then the same thing again.
What else is there that can possibly be causing this to happen?

This is starting to sound like it is not a USB communication problem. To make sure that the USB communication is working, I’d like to know some more about what is happening. The next time the problem happens, please unplug the Maestro from USB, close all programs using it, then plug it back in, and open up the Maestro Control Center. Does the Maestro Control Center display the serial number of the Maestro in the upper left? Are you able to drag the slider for your servos? If so, does the green/blue dot on the slider move with it? What is the green LED on the Maestro doing?

- Grant

As per your instructions I hooked up the Maestro and tried to make it work.
It has a been a few days since I tried it so I figured that it would work but ti did not.
The Pololu Control center does display a number in the upper left corner in the drop-down box.
The sliders do move And there is a blue dot shown when you move the slider.
The green light on the board flashes but the servos do not respond.
I tried this a few times and each time was the same result.
I also tried the 6volt battery pack and had the same results.
I checked under the errors tab and no errors are showing.
I also tried restarting the device and this had no effect on it working.

If you are able to see the green/blue dot in the Maestro Control Center move, the Maestro is communicating with the computer, so it is probably not a USB noise issue. I suspect the problem is related to your power supply or servos. Could you post pictures of your setup? If you have an oscilloscope, could you verify that the Maestro is sending signals when the problem occurs?

- Grant