Low Voltage Dual Serial + ARM7 (2138)

I have a robot with a AVR Mega168 running 2 motors. The battery is 3.7V 10AH. The battery directly powers the motors through a FAN8200 and powers the processor through a 5v step up board. It works great. I know there is enough power to run the Mega168 and the FAN8200.

Now comes the problem. I have a NewMicros Pluga2138 ARM board. I wish to use the ARM to control the Low Voltage Dual Serial Motor Controller.

It wored OK when I had the ARM in the development board and had wires running to my robot base. The LEDs show config worked, then later Forward and Reverse. and the motor worked great.

Now I took the ARM off the development board. I hooked the 5V step up board to power the ARM (which then generates 3.3V). Nothing. I couldnt even get the config to show up.

I put the ARM back in the development board and tried again. This time no LEDs at all. I disconnecte everything back to the robot base. Now I get LEDs.

I hooked up the Motor supply voltage (3.7V), still OK.

As soon as I try hooking up 1 of the motors, all of the LEDs go off and stay off until I unhook the motor and go through a power up.

I put in a second board and it has the same problem.

Config = 0x80,0x02,0x02
Power down board and run with:
run=0x80,0x00,0x05,0x60 + 0x80,0x00,0x07,0x60

Are they FRIED?

I have only 1 left, still sealed in with the manual. I dont want to fry this last one. So, what do I do?



It’s hard to tell what’s wrong from what you’ve described. Can you post pictures of your setup? What are the specs on your motors? Do the bad boards smell like something burned out?

In general, inconsistent performance can be indicative of noise issues, which can be caused by bad power distribution and wiring. Bad or sloppy connections could also explain things working in one setup and not in the next. It sounds like the behavior changed every time you rewired things, so perhaps you made a bad connection (or left some out). The motor controller does not have reverse power protection, so that’s one thing that could instantly kill it.

Do you have access to an oscilloscope? It would be helpful to look at both the control signals and your power lines. If the LEDs are working as expected but adding motors makes things stop working, it could be a power supply or noise problem.

- Jan