Loopback failing 'Pololu Deluxe Serial Adapter'


I am trying to recover my data off of my seagate drive per instructions here (mapleleafmountain.com/seagatebrick.html)

I have purchased all approved/suggested items from robotshop.ca, but I cannot get any sort of echo from the device when I set it to loopback to itself.

I have;
confirmed I am getting power to the chip via power supply
checked, rechecked and double checked all my connections twice
tried three machines (win 7, win xp and a laptop running win xp) all no go
tried putty as well as hyper terminal
tried all new power connections
tried different baud etc rates.
had a good night sleep and tried it all over again.

I am thinking it maybe a bad board (i have that kind of luck) but there is not alot that could be wrong with it and I have no idea what the failure rate is on these.

One thing i did not find was any drivers for this thing… on the old laptop it is asking for drivers for a modem, but i have no drivers for this thing.

Any suggestions?


I have started asking people who call with problems about the adapter if they are doing this hard drive recovery, and I think they all have said yes (though it’s only a few customers in several months). Do you work with electronics besides in this case?

You do not need a driver for our adapter, but you might need one for whatever actual COM port you have. Have you done the loopback test on the port itself?

How have you confirmed the power to the board? Did anything get hot?

- Jan

I don’t work in electronics, but I do have a good understanding of basic eletronics and mean soldering skills. in the past I had a personal interest in Direct tv and free to air, but gave up on that when it became a hassle and I had kids. I am liking this site and think that i may start into this as a hobby, but right now… you decide what I know.

So, back to your question. I know I am getting power TO the adapter as I put my voltage meter on the gnd and vcc (solder side) and I was getting numbers. I will go back and test to see exactly what the voltage I am getting is. It should be 5 as I am pulling power from the yellow line of my power supply.

I never knew you could do a loopback on the port itself. I assume you mean without your adapter?? I will google that and try it out .

as a rule I do check for heat and there was none (or at least nothing to the touch)…

The com port on the PC’s seem to be fine (excep the old latptop) but again I have never used it, so I may have to give that a google as well… it just seems unlikely that it is a com port issue as no one else seems to have mentioned a problem with com ports (but I will take another look).

I may jsut order another unit and see if it maybe an issue with the one. any reason to buy more of your products the better.

I think yellow on computer power supplies is 12V, which would destroy your adapter instantly. I don’t know what you mean by emphasizing “problem”. Your port could be fine and you could be trying to talk to a different one. When you are doing a loopback test through the adapter, there are a bunch of things being tested (e.g. your port, drivers for it, your terminal program, what you are doing with the program, your cable); by doing a loopback test of everything but the adapter, you can have confidence that the problem is with the adapter.

- Jan