Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

Link pololu trex to reciver


I have look up all the details but 1: can’t update firmware and 2: can’t get the 12amp 7.2volt motor to turn over
I think the first problem is the main one .
I have try running the code via a arduino uno .



What file did you use when you tried to update the firmware? Do you have a link to where you got the firmware? Could you tell me more about your setup? What are you using to supply power to the TReX? Are the LEDs turning on? If so, which ones and what are they doing? How do you have things connected? Could you post pictures showing your setup and your connections?



Sorry for the delay .
I worked out the problem. I tried to use a serial command while the Trex was pinned for rc mode
So I have got hold of a usb to ttl cable to program the Trex directly .
If I have any problems sound it this way I’ll come back to the forum for help
But the you for coming back to me


I am glad you able to get your TReX motor controller working. Thanks for letting me know what was wrong.



Silly question I know the Trex is made only for motor .
I’m trying to use it for an rc car but need to use a servo for steering what the best and safest use way without made over powering the battery
I’m using a 7.2amp 12v motor
And a 7.4amp battery
Any ideas


Servos can usually be plugged right into your RC receiver and draw power directly from your battery. However, you should check to make sure your servo can handle the voltage supplied by your battery.

Batteries are usually rated for their capacity (e.g. mAh), not current, so you might want to double check your battery rating. You might find this blog post on battery capacity helpful. If your battery cannot supply enough power for all the things in your application, you probably need a more powerful battery.



The battery I’m using on the rc car is a 30c 16.3wh 2s1p 200omah
or in short 7.4v 66Amp
That would in theory be enough to power both


I have a problem the motor works if servo isn’t plug into receiver, plug the servo in motor hums bit won’t turn over .
Servo plugged into channel 1 on the board and 3 on receiver
Motor plugged into channel 2 on board and 1 on receiver
… what am I don’t wrong?



Are you connecting your RC servo to the motor outputs of the TReX? Could you post a diagram or picture showing how you have things connected?



No directly from servo to receiver
The motor is connected from the Trex to the reciver



It is hard to help you troubleshoot unless you post a diagram or picture showing how you have things connected?



as requested
Hope that helps?


It sounds like you might be having a power issue. How are you powering your servo? Are you powering it through the TReX? Could you post a picture of your actual setup showing how things are connected?



Yes will do that when home tomorrow
The servo is connected to the reciver which is powered from the Trex


It sounds like you are powering your servo through the 5V regulator on the TReX. The linear regulator on the TReX can only safely supply a maximum of 100 mA when VIN is 16 V, and is not appropriate for powering servos. If you want to connect servos to some of your RC receiver channels, you must power your RC receiver separately and disconnect the BEC jumper. Attempting to use the TReX’s regulated Vcc line to power servos can permanently damage the TReX.

If you are not powering your servos from the TReX can you post a picture of your actual setup showing how things are connected?