Limited Vref for DRV8825


I recently bought a DRV8825 stepper motor driver. I have attached the driver as per the website recommendation. I am using full mode stepping and currently have nothing attached to the output.

I am trying to set my current limit. I am using a 12V motor supply, and have clocked the step pin at 1kHz. When I go to measure the Vref pin, I get a value between about .5V and .8V. I have turned the pot all the way to both ends, and can’t get a voltage outside that range. I know I should be able to get 0V to 3.3V, but I have no idea why I am not. I am definitely turning the pot as far as it is supposed to turn. The motor I am using has a very low rated current, so I need to have Vref be much lower.

If anyone has any ideas with this is, I would appreciate it.



Can you try disconnecting everything except for motor power and the sleep pin (the VREF supply is disabled when the driver is in sleep mode) and measure the VREF via with your multimeter? Do you still get 0.5 to 0.8? Can you post a picture of your setup?

- Ben

I disconnected everything and did what you said. The only pins connected are the SLEEP pin to 3V, the motor supply to 12V and the two ground pins. I measured about 39.5 mV regardless of what the potentiometer was turned to.

Here is a pin out of what I had previously wired:

1 - GND
2 - GND
3 - GND
4 - GND
5 - 3V
6 - 3V
7 - 0-5V Square wave @ 1kHz
8 - 3V
9 - GND
10 - Open
11 - Open
12 - Open
13 - Open
14 - Open
15 - GND
16 - 12V

All grounds are tied together at the power supply.

I just tried putting it back to the way the circuit was before. This time Vref was around .2-.3V over the range of the potentiometer. I was only able to look at it for about a minute before I could tell things were heating up. I shut off the power, and the chip was very warm as was my ground pin (pin 9).

I’m not sure what this means, but hopefully someone knows.


Just to be clear, the driver was getting hot even though there was nothing connected to the motor outputs?

Can you post a picture of your setup?

- Ben

That’s correct. Nothing was attached to motor outputs.

I can’t really post a picture (no camera and phone is broken).

There really isn’t much to show though. I have the driver on a breadboard with the pinout I specified above.

If it’s getting hot with no motor connected, then there is probably a short somewhere. I suspect the board is damaged, but a picture might let me see if there is some other possible explanation (or help me see what might have caused the damage). I don’t suppose you can borrow a friend’s phone or something?

Also, it’s a little strange to me that you have a 5V signal on the step pin but 3V on the sleep pin. What exactly are you connecting to the driver? What is your power supply?

- Ben

Yes the board was damaged. I used a different one and now it works.

Thanks for the help.