Jrk Configuration Utility CRASH

I have a laptop that I have installed the Jrk Configuration Utility v1.2.1.
Actually I have installed and uninstalled it many times in an attempt to solve the problem described below.

Upon startup of the utility, it always and immediately crashes wth “Pololu Jrk Configuration Utility has encountered a problem and needs to close”. No other information is provided.

I use this same configuration utility on various other PCs without any problem. Each, including the laptop, is a Windows-XP Pro SP3 system, with MS .NET 3.5.

Note: I do successfully communicate with and control multiple Pololu USB Motor Controllers with Feedback from this same laptop. I just can’t run the configuration utility on the laptop w/o it crashing.

Any ideas?


I’m sorry you are having trouble with the jrk software. Could you try running JrkCmd at a Command Prompt? It shares a lot of code with the Jrk Configuration Utility and if it crashes it will probably give you a more informative error message.


Unfortunately, I do not have jrkCmd. It appears to be in the Pololu SDK, which I have never downloaded (had no need). Is there just a copy of an executable “jrkCmd” somewhere that I can download?

Sorry, I forgot that JrkCmd is not installed along with the Jrk Configuration Utility.

Please try running the precompiled version of JrkCmd available in the attached zip file:

jrkcmd- (34.2 KB)

This is version, compiled by me from the latest release of the Pololu USB SDK, using Visual Studio 2008. I tested it on my Windows Vista 64-bit machine and it worked for me. You will probably need to extract all the files to a temporary directory to make it work correctly.

You should try these two commands:

jrkcmd -s



Thanks for the jrkCmd app. I’ve tried it using the suggested, “jrkcmd” and “jrkcmd -s”, but unfortunately both act the same; Both crash with no additional information, just the same error “JrkCmd has encountered a problem and needs to close”.

The laptop I’m trying to run this code on is a Dell Latitude D620. My custom motor control code that works without error communicates via the virtual comport method. Your jrk utility and jrkcmd use a native interface (?). I guess maybe there’s an issue with talking to the USB ports on this laptop directly?

Any other ideas?

Thanks for your help.

The behavior you are describing makes me think that there is something wrong with your installation of .NET 3.5. If you run jrkcmd with no arguments, it doesn’t even try to access the USB port, it just tries to print a help message on the screen.

I suggest uninstalling and reinstalling .NET 3.5. If that doesn’t change anything, and if this is within your abilities, I suggest downloading Visual Studio C# Express 2008, and just creating a new program for .NET 3.5 and see if you can get it to run at all.


Thanks for your time.

I actually went through the process of un-installing/re-installing .NET prior to looking for help on the forum. I’ll try it again. If it doesn’t work after that, I’m done…and will conclude there’s something flaky with the laptop hardware or OS or .NET or ???.


Just a final note:
I COMPLETELY uninstalled .NET from the laptop, which included ALL the previous versions as well as service packs of .NET

I then did a clean install of .NET 3.5 which put the following on the laptop:
MS .Net Framework 2.0 Service Pack 2
MS .Net Framework 3.0 Service Pack 2
MS .Net Framework 3.5 Service Pack 1

Rebooted and tried:
jrkcmd …it crashed as per my previous posts
jrkcmd -s …ditto
jrk configuration utility …ditto >crash<

That’s it.