JRK 12v12 Coast one direction, brake in the other

Hi

I posted this onto the end of an old thread earlier, but I think it needs it’s own. Sorry if I’m wrong.

I’m getting a strange effect on the 12v12 with the UMC02a upgrade both with and without the deceleration mod. However, I don’t know how to revert to the original to prove if it’s the upgrade.

This is the problem. If I apply full joystick input and then suddenly let it drop to centre, in one direction the motor appears to coast and in the other it comes to an abrupt stop.

Playing with the settings I can make a nice acceleration in both directions, but from the ‘max’ joystick position a nice decel and from the ‘min’ joystick position the start of a nice decel and then the abrupt stop again.

It works fine with the 21v3 and its deceleration firmware.

Any thoughts?

Many thanks

Keith

Hello, Keith.

I am sorry you are having trouble with the jrk.

You can revert to the original jrk firmware by following the instructions in the “Upgrading Firmware” section of the jrk user’s guide.

Could you save a jrk 12v12 settings file using the jrk configuration utility and post it here so I can see what settings you are using and try to reproduce the problem? Please be sure to post the settings you were using when you observed the problem.

–David

Hi David

I thought I’d go back to basics to discover what this problem could be.

So, I named my two 12v12s ‘Blue’ and ‘Red’ after the cable ties around each board.

  1. ‘Blue’ 12v12, reinstalled firmware to the plain umc02a_v1.3.pgm.

  2. Set feedback to ‘none’.

  3. Manually set target to 2848 as an example. Motor runs.

  4. Set target to 2048 motor coasts, despite the default setting of ‘brake’.

  5. Set target to 1248. Motor runs.

  6. Set target to 2048 motor stops dead.

  7. No other settings were changed.

  8. Changed board to ‘Red’ and repeated steps 1-6. Exactly the same response as before.

Other notes:

These symptoms are the same with different motors and with and without joystick attached (but obviously not used).

The boards were powered by a 12v lead acid battery with and without 13.38v charger attached.

With speed set to zero, and a confirmed output voltage of 0v, motor shows resistance (same as shorting wires,
and no, I didn’t short the output!) in one direction but not the other.

I think this last point is significant. The boards are shorting the output in one direction only.

Using a 21v3 with ‘standard’ firmware and using items 1-6 as before, the motor brakes sharply in both directions equally.

Changing to the deceleration firmware and using either the joystick in analog mode, or manual input in serial mode, produces nice acceleration and deceleration in both cases.

I haven’t bothered to do more tests with the 12v12 deceleration firmware because I think the problem is more fundamental.

These boards are 2 years old but haven’t been used apart from trying to set them up. There’s a code on the back, in case that’s useful, of ‘OJ1598’ plus ‘umc02a’.

I’ve attached a zip of the settings files from the two 12v12s (which are identical), and the 12v3 in both standard and deceleration firmware.

Phew!!

Sorry to go on for so long but hopefully I’ve bypassed some questions you may ask.

Over to you!!

Keith
brook.zip (2.25 KB)

Hello, Keith.

Thank you for the precise description of how you caused these symptoms. I have reproduced the problem here. It is a subtle issue and we are working on it.

–David

David

That’s reassuring in one way. It proves I haven’t blown up my boards with something stupid.

Standing by.

Keith

Hi David

Any progress on a solution to the problem?

Keith

Yes.

Just today we released a new version of the jrk 12v12 firmware that should fix the problem you are seeing. You can find out more in the “Upgrading Firmware” section of the jrk user’s guide. You can configure the jrk to either brake or coast when it goes to duty cycle 0, and the effect will be the same no matter which direction the motor is spinning.

Please let me know if it works for you, and let me know if you encounter any problems with the new firmware!

–David

Hi Keith.

How is the new jrk 12v12 firmware working for you?

–David

Hi David

Sorry, been away. Will test in the next few days.

Has it worked for you, and any idea what was the fault?

Thanks

Keith

Yes, I tested the firmware before releasing it and it worked for me. The problem was that previously, at a duty cycle of 0, the jrk 12v12 would brake the motor in one direction but let it coast in the other direction. This is because it left one of the high-side MOSFETs on and the other one off. In the new version, you can choose if you want to brake (both low-side MOSFETs on) or coast (all MOSFETs off) when the duty cycle is zero.

–David