Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Imu01c


#1

Hello
I am trying to connect two IMU01c to an Arduino UNO, to read accelerometer and gyroscope data, but I have problems to read this two devices. Can anybody help me?

Thanks


#2

Hello.

I am sorry you are having trouble reading multiple MinIMU-9 v3. Can you tell me more about your system and issue? What specifically is happening when you try to read your devices? Are you driving the SA0 pin low on one of your MinIMUs? Can you post the simplest version of your code that should work but does not? Also, how are you supplying power? Can you post pictures that clearly show your setup?

-Jon


#3

Sure Jonathan, and thanks for your answer.

I am using an Arduino Uno, I connected the IMU as is shown in the figure:

My problem is that I can’t access to one IMU and read the gyroscope data and then access to the other IMU and read the gyroscope data. My code in Arduino is shown in the next figure:

When I run the program and Open the Serial Monitor af Arduino I can see the gyroscope data but, the data is not separate, it means if I move one IMU01C the data is register for the two IMU, so that I can’t read just one IMU data and the other.


#4

Hello.

The SA0 pins on these boards are not level shifted and should not be connected to a 5V source(we have a warning about this on the product page). That pin is pulled high (to 3.3V) by an onboard resistor, so you might try to disconnect it and see if you can get it to respond.

The Wire. functions in your code are not necessary to read the sensors; the gyro1.read() and gyro2.read() functions should work by themselves.

Can you post photos of your connections here so we can trace all of the connections?

-Nathan

EDIT: This second block of code in this forum post might be helpful for you.


#5

Thanks a lot!!

The code of the forum works perfectly, and solved my problem.

I also connect the SA0 to 3.3V.

Thanks.