How to determine if Motor Controller 2s9v1 is broken?


I’m trying to connect two small brushed motors to a 2s9v1 and run them from a linux box through serial adapter. I’ve attached a photo showing my wiring; I’ve added labels to the 2s9v1 (which are on the back) for convenience.

The logic is powered by four rechargeable batteries, which should put out about 4.8V. The motors are powered by a mains adapter which puts out 4.8V as well.
At the moment only one motor (M0) is connected.

When I’m trying the demo mode the green LED flashes (and the red stays off), but the motor won’t turn. When I’m trying to send commands with the Serial Transmitter Utility I receive no response (I think in demo mode every command should be returned).

I’m really new at this, so it is entirely possible I’ve did something stupid (like connecting the wrong pins) at one point or another and inadvertently destroyed the 2s9v1 - is there some way to test this hypothesis (apart from just buying a new device)?

In the meantime I soldered the pins to the 2s9v1 to make sure they are connected - which doesn’t fix the issue.


Hello, Johann.

What are the two short white wires in your picture near the upper GND pin of the qik? It looks kind of like one of them is shorted between GND and M0-. Other than that, I don’t think I see anything wrong with the setup in your picture other than the lack of solder (just resting the board on the header pins will not allow it to make reliable connections), which it sounds like you’ve already corrected. Could you post an updated picture so we can check how your solder connections look?

- Kevin

Hey Kevin,

the white wires are helping the connections… I’ve soldered everything together now and simplified the setup. Everything is now powered by the mains adapter with 4.48V.

I get the heartbeat, but thats about it. I’ve tried the demo mode, and I’ve tried the troubleshooting section in the manual:

When I do that, I do get a red light after sending 0xBF, but it doesn’t turn off at 0x82. I receive no response from the device either.

Any help appreciated!


I reread your first post and noticed you were originally powering your logic from a 4.8 V battery pack. This is a bad idea because a nominally 1.2 V rechargeable battery can easily exceed 1.5 V when it is fully charged, meaning that four of them could be over 6 V, which could damage both the serial adapter and the qik.

In general, logic voltages should be supplied from a well-regulated source; your mains adapter might work for that as long as it outputs a stable voltage, but if you are trying to power the motors with it too, you should at least add some decoupling capacitors to prevent the motor noise and current draw from affecting the logic. You might actually want to consider powering your logic with the mains adapter and powering your motors with the battery pack (the reverse of what you were originally doing).

How much current is your adapter rated for, and what kind of motors are you using?

Are you sure you are succesfully entering the demo mode on the qik? Do you see both the red and green LEDs turn on and off in demo mode without your motors connected? If you then activate demo mode again with the motors connected, what happens? What command or program are you using to send the serial commands for the serial connection test?

Finally, it is hard to tell from the picture, but it looks like some of your solder connections might be suspect. If any of the pins have a dull round blob of solder on them, you might have a cold joint that is not making a good connection. A good solder joint should look like the ones on the serial adapter: they should be shiny and volcano-shaped, forming a smooth slope between the header pin and the pad on the board.

- Kevin