Help controlling Micro Maestro from python / Linux


I just got one of these micro maestros today. I have been having some trouble getting it work with a python script. The mono program worked fine from the beginning, but when trying to use it with some python scripts found from these forums, I get nothing. I also tried writing my own script with the help of the manual.

import serial

ser = serial.Serial('/dev/ttyACM0')  


#compact protocol
#pololu protocol
#mini SSC Protocol


Running this script makes the controller blink lights but I get no movement on my servos. I also noticed that the mono program can’t make the servos move if the baud rate is set to autodetect. The control center just gives an warning about having to wait for the baud rate detection and when trying to control the servos, they remain still.

I have the same problem. When I run python script, led on Maestro servo controler is blinking, but servo doesn’t turn. Could you help me?


Sorry for the slow reply. I am splitting these posts off from the original topic, which was about getting the Micro Maestro to run on an embedded linux board.

Anyway, to help either of you, it would help if you told me which LEDs are blinking and how, instead of just saying that they are blinking, and I would like to know more about your setup and exactly what you have gotten to work already.

Artsi, from what you said, you had your Maestro configured in auto-baud-detect mode, which would prevent the servos from moving until a 0xAA comes in on the TTL serial port (which would be never, in your case). You need to configure it for USB dual-port mode if you want the USB COM port to accept serial commands. I can’t tell from your comments exactly which mono program worked “fine”, and what that means. You say that you got the warning about it not working, and then it did not work, which sounds pretty consistent to me! However, if you have reconfigured it, can you tell me what you changed, or post your configuration file?

Andrew, you have provided almost no information. How are you powering your servo, and does it work from the control center? Have you done any configuration?