Having issues withMaestro 12 Servo Controller

I’m trying a very simple script to move a servo based on a sensor input and I’m having issues. I’m using a digital servo so at first I tried a period of 3msec, multiplier 1 (333Hz) and even later I changed it back to the default 20 msec period but the output does not exist. I’m looked at the output of channel 1 on a oscilloscope and there are no pulses. The status panel shows channel 1 following the input but the pulses are not there. Any suggestions would be appreciated.

    0 get_position		# get the value of the sensor, ~102-922
    7 times 2416 plus	        # scale it to ~3130-8870, ~ 0.78-2.22 ms
  1 servo


Can you try removing your Maestro from your system and testing it separately just using the slider in the status tab? Preferably, you should do this test with just USB connected (no servo power or servo), while monitoring the signal pin on channel 1 with your oscilloscope. If you still do not get a valid signal, can you post captures from your scope as well as pictures showing how you are connecting the probes to the Maestro? Also, can you post your Maestro settings file? You can save your settings file by selecting the “Save settings file…” option within the “File” drop-down menu of the Maestro Control Center.


Thanks Brandon,

So I did sort of what you suggested. I stopped the script and used the slider to move/repositioned the servo and it worked. Then I looked at the signal on the o-scope is it is present. However, this time the there servo was still connected. (originally the servo was not connected). But now the script seems to be working fine. Any idea what happened?


I am glad it is working for you now. Based on the descriptions you have given, I do not see anything suspect that would have caused a problem.