Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

FC90 Servo with Feedback and Mini Maestro 12


#1

Hello,

i tried the Mini Maestro 12 with the FC90 Servo with Feedback and also the FS5103B-FB,
and cannot get them to run.

Tried also some old Standard Servos, no Problem.

Do the Feedback servos need the feedback line to do something?
I thought i could use them as normal, and when i want to add the feedback line later when needed.
I didn´t find anything here in the Forum or any documentation.

My first try was mit an old power adapter with 6V 0,8A, but then i measured that it had 8,0V.
Can it be that i blew the servos with this current?

Thank you in advance for Help,
Robert


#2

Hello, Robert.

We do not carry a “FC90 Servo with Feedback” Are you referring to the FEETECH FS90-FB Micro Servo with Position Feedback?

Both the FS5103B-FB and FS90-FB servos can be controlled normally while ignoring the feedback.

I have a couple concerns about your power supply; the nominal operating voltage range for these servos is 4.8V to 6V, so the 8V you measured is a little too high. Additionally, you should probably be using a supply that can source more current (preferably around 1A per servo or more). Could you try a different power supply that meets those requirements?

Brandon


#3

Hello Brandon,
Yes second try was with a Laboratory power supply 5-6V max. 10A. But the feedback servo didn’t make anything. No noise no move, and i did the same things as with the conventional servos.
Tried it on different channels…


#4

Can you confirm whether or not you are using the FS90-FB micro servo? Also, how many of each servo are you using?

Could you post some pictures of your setup that show all of your connections? How are you controlling the Maestro channels during your test? Could you post your Maestro settings file as well? You can save your Maestro settings file by selecting the “Save settings file…” button under the “File” drop-down menu in the Maestro Control Center (while the Maestro is connected).

Brandon


#5

Yes i use the FS90 and the FS5103B Servos with Feedback,
and it didn´t matter how many i have used.

Both do not move.
Attached you find the pics and a Video, and also a config file.
Robert
maestro_settings.txt (2.9 KB)

https://forum.pololu.com/uploads/default/original/2X/3/3fce5c203afa74a8b1afbe1d7d977f197677a1ee.mp4


#6

Thank you for posting that information. It looks like you are running the servos using a sequence you set up in the “Sequence” tab of the Maestro Control Center. However, the sequence in your settings file (Sequence 1) only moves the servos on channel 0 and 4, which seems to match the behavior shown in your video. It looks like servo channels 1, 2, and 3 in your sequence stay in the same position the whole time. Are your servos actively holding position when you run the sequence?

Can you try testing each servo directly by moving the sliders in the “Status” tab of the Maestro Control Center?

Brandon


#7

Hello Brandon,

sorry, i posted an old file.
The error is not that i didn´t try to move the right slider.
I tested all sliders, different speeds,… the 2 servos with feedback did never move, the other 2 conventional did.
So, can i check if i blew the servos with too high voltage on my first try (8 Volts)?


#8

The questions I asked in my previous post are intended as a test to see if those servos might have been damaged. As I mentioned, from your video they seemed to be doing what your sequence is specifying. Are they holding position when the sequence is running? If so, that is a good sign. The easiest way to test them would be to remove all of the servos, and connect a single servo at a time and try to use the slider in the “Status” tab to move it (note that you should make sure the sequence is not running during the test).

Brandon


#9

Hello Brandon,
yes i understood, and i checked it - no motion…