Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Fatal error: opening dependency file

I’d love to be building robots and learning C/C++ right about now, but sadly this is not the case. I can’t build any files using pololu’s avr libraries. Following the Library User’s Guide, I got to step 6 and immediately ran into problems. When I double click on the simple-test aps file and AVR Studio runs, the build window displays the following:

Loaded plugin STK500
Loaded plugin AVR GCC
Loaded partfile: C:\Program Files (x86)\Atmel\AVR Tools\PartDescriptionFiles
Error Code: -2147467259:

If I select Build > Build, as per instructions, I get the following in the build window:

Build started 11.9.2009 at 17:18:12
0 [main] sh 3188 sync_with_child: child 5860(0x14C) died before initialization with status code 0x0
92844 [main] sh 3188 sync_with_child: *** child state waiting for longjmp
/usr/bin/sh: fork: Resource temporarily unavailable
avr-gcc -mmcu=atmega328p -Wall -gdwarf-2 -std=gnu99 -Os -funsigned-char -funsigned-bitfields -fpack-struct -fshort-enums -MD -MP -MT test.o -MF dep/test.o.d -c …/test.c
…/test.c:23: fatal error: opening dependency file dep/test.o.d: No such file or directory
compilation terminated.
make: *** [test.o] Error 1
Build failed with 1 errors and 0 warnings…

I have no idea what the problem is, though I suspect it is something obvious and simple. Help would be appreciated.

Hello, teraflop122.

What operating system are you using? I got the “child state waiting for longjmp” error in Windows Vista 64-bit. I think I fixed it by following the advice from this article:

madwizard.org/electronics/ar … inavrvista

-David

You know, the first time I tried that, it didn’t work. After trying the same exact steps just now, everything is working. Clearly my computer is trying to crush my mind.

I can program the sv-328 now, but I still get Error Code: -2147467259. Does this mean anything?

I also get the same error code whenever I start AVR Studio, in the Message pane. But I can compile and program my AVRs just fine so it doesn’t bother me.

I have no idea what the error code means, but I searched Google and found some people discussing it who also don’t know what it means but they know more than I do:

-David