Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Error Always Present


#1

I’ve got a 18v7 Simple Motor Controller that I’ve been using for some time with no issues and it is currently outputting 2.5V on the error line (ERR LED in red) even when an error is not shown in the Motor Control Center. When a valid error condition is present the ERR line has 3.2V as expected.
I’m aware this could have been caused by a number issues (power supply startup, unintentional shorts, etc). I’ve seen this same issue described in another post or two, and it looks like it has been solved with an RMA. Is there a recommended component fix for this and what is the recommended protection to prevent this?


#2

Hello.

It is not clear why that LED is on. Can you send me pictures that show how you have your board connected? Could you point me to the other posts where you saw this same issue described? Does the controller currently work, otherwise? Did anything in your system change in between the time the Simple Motor Controller was working and when the red LED started staying lit?

-Nathan


#3

Nathan,
Here is a picture. In order from left to right, Vin is power supply (reg 24V), OutB/OutA go to DC brushed motor, GND is tied to power supply ground and to daughter board, 5V supplies sensor on daughter board, and daughterboard sensor outputs 0-3.3V (relative to gnd) into A1. ERR is out to 3.3V relay.

I thought the error described below was a similar issue, after reading more closely it is different as I cannot see the error in the motor control center.

The motor controller works otherwise, I’ve just had to disable the error detection. I’ve got a handful of these boards on hand and if I drop a new one in its place it works as expected. The one that has the issue is probably about 3 years old.


#4

Does the LED still turn on if the ERR pin is disconnected from the relay? Are there any other components like a FET and flyback diode in your relay circuit, or does the ERR pin drive the relay coil directly? Also, if you post pictures of the other side of the board, I can look for any shorts there.

-Nathan


#5

The LED is still on if the ERR pin is disconnected. I also tried to pull the error line down by attaching the error output to ground through a 3.3k resistor, but that did not help.
The 3.3V error out is an input to an optocoupler which isolates it from the actual relay.
Pictures of the other side of the PCB below:


#6

Thanks for the picture. I do not see any obvious shorts. Could you test the resistance between the ERR pin and the RST pin with a multimeter? If there is no connection between those, it is likely that the pin on the microcontroller is damaged. If you contact us with your order information via email at support@pololu.com, we will see what we can do to help you out.

-Nathan


#7

With no power applied to the board resistance between ERR and RST is about 6.35 Megaohms.


#8

That seems like the sort of measurement I would expect from a multimeter if there is no short. If you contact us with your order information via email at support@pololu.com, we will see what we can do to help you out.

-Nathan