Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Erratic servos mini maestro 12

I’ve read all over the forums that servos going crazy is usually a power supply issue, but here is where I am at.

  • I have a variable power supply and I’m giving the maestro a constant 6V 5A.
  • 7 servos are connected and they operate between 4.6-6V
  • As I enable each servo, everything is ok up until I enable the 7th
  • When I enable the 7th they go crazy

I’ve measured the amps and it isn’t going above 2A at any point, the voltage remains constant the whole time. (1.8A is when they are all going crazy)

I’ve also measure the voltage on the servo rails, it decreases dramatically as servos start moving, but I’m confused how it would be possible to provide the rail 6V and expect to have them all function at the same time?

I’ve tried several computers in case of a usb port issue
I’ve tried with the jumper both on and off
I’ve tried an external power for the maestro board it self while another supplies the servos

I can’t for the life of me work out what is causing it

Hello.

Especially if the voltage is dropping when the servos move, that is a sign that your power supply cannot deliver the current that the servos are trying to draw. Have you looked at the supply voltage with an oscilloscope to see what it’s doing? Can you post some pictures of your setup?

-Ryan

I fixed it,

I think it was having an initial spike over 5A that couldnt be detected, but also changed to thicker wires and a better power supply

2 Likes