Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

DRV8825 on RAMPS 1.6 Vref = supply voltage? [SOLVED]

#1

I have just assembled by Arduino Mega256/RAMPS 1.6 sandwich, installed the drivers and tried to set the current limiting… but I just get the full supply voltage (24V) on the Vref via (with respect to the -ve supply). I get the same on all four drivers installed.

BTW My steppers are not connected but are MoTech MT-1702HS133A motors that have a 1.33A/phase current limit… so I was looking for about 0.66V on Vref.

BTW2 The RAMPS D1 diode has been removed to stop it backfeeding 24V into the Arduino.

Should I be testing the Vref with just the 5V supply?

#2

It seems that I have fallen prey to a scam. What I was told were genuine Pololu drivers aren’t. The Vref via isn’t connected to the center of the pot, but is connected directly to Vmot.

By measuring the voltage on the pot wiper itself, I get sensible readings and have managed to set my current limits.

#3

Thank you for letting us know you found the problem. Yes, there is a know issue with some knock-off DRV8825 drivers with that problem.

-Derrill