DRV8825 board only got 2 microstep modi working

Hi,

Last week i bought a pololu drv8825 driver board with steppermotor.
Everything connected and works however…not fully.

If i try al microstep modi, only full and 1/16 microstep are working.
I have checked the three connections (M0, M1 and M2) and measured the states on the board.
Looks all good.

this is whats happens.

if i choose full, 1/2, 1/4 or 1/8 the result is always full step
if i choose 1/16 or 1/32 the result is alway 1/16 microstep

I also played with the current limiter but with the same results
Powersupply is about 12V
I also have tried an other stepper (less current) with the same results.
changing the speed has the same effect.
I use 2 phase stepper

Can the driver be defective? or do i something wrong.

Kind regards,

Chris

Hi, Chris.

From your description, it sounds as if your M0 and M1 pins are always low. Can you double check your solder joints and connections to those two pins? Could you post some pictures of your setup including all connections? What stepper motor are you using and what is your current limit set to?

-Derrill

Hi Derrill,

Thanks for your answers.

You conclusion is correct but…

I’ve checked and measured (scope) again direct on the IC pins 23-24-25 and the right states are there.

I’ve tried two stepper motors with same results.

  1. this is one http://reprapworld.com/?products_details&products_id=94&cPath=1614
  2. the other is al small one form a copier this one:
    http://www.nmbtc.com/pdf/motors/PM35S048.pdf

The current, i’ve not calculated en measured as described but tried when running, turn the pot from min to max.
No difference at all.

Pictures in attachment:

youtube video:
https://www.youtube.com/watch?v=-pmUNie_0qA

The reset and sleep connection are joint together and have 5volt
The step, modi and turn connection are connected to a pic controller.
The power supply is about 12Volts

Other suggestions?

regards,

Chris




We test the microstepping functionality of each board, so what you are describing is unlikely to be a board defect. I am not sure if it was just a typo on your part, but please note that the microstepping pins are 24, 25, and 26 on the DRV8825 IC, not 23, 24, and 25.

Did you specifically configure your PIC control board to output the appropriate microstep control signals for the DRV8825? I think you should simplify your setup by manually setting the microstep mode (i.e. make the pins high or low by connecting them directly to ground or 5V) and applying a the same step signal for each test case (in your current setup, it looks like the number of steps is changing every time the microstep mode changes).

Also, a proper current limit setting is crucial for microstepping, so you really should set that to a specific, appropriate value as described on the DRV8825 product page (see the note in the current limiting section about microstepping). Just randomly sweeping the pot is not a sound strategy.

-Derrill