DMC01 via Virtual COM problem

I’m using a TReX DMC01 and it works fine with the configurator application (when connected directly to the PC) - but when I connect via an RS232 to Ethernet converter using a virtual COM port the configurator hangs when I try and connect.

I get a loop back from the controller using HyperTerminal and I have tested the RS232 to Ethernet converter with various other serial devices and they have worked fine, anyone any ideas?
Many Thanks:


Are you sure you’re connecting your adapter correctly to the TReX? Specifically, do you have it connected to the TReX’s RS-232 pins (RX and TX), and do you have a common ground between your adapter and the TReX? Can you see if you have the same problem if you use the Pololu Serial Transmitter utility (or some other terminal program) to send raw commands to the TReX? I’m wondering if the problem is with the configurator software or with the communication between your device and the TReX itself, so any tests you can perform to narrow down the location of the problem would be helpful.

- Ben

Hi Ben,
Very many Thanks for the response, I tried the Pololu Serial Transmitter utility as suggested and it worked perfectly, the 232-Ethernet device I’m using is the NETRS2321EGB from StarTech, possibly the configurator conflicts somehow with this particular VP application!!

Thank you for the detailed information about your setup; I will do what I can to track down the problem. In the meantime, if you’re interested in exploring it further, please take a look at this document:

It provides a C# program (Visual C# 2008) for sending commands to and receiving data from the TReX and TReX Jr. The sendCommandPacket() method is a simplified version of the one used by the TReX Configurator application. Perhaps you can run this program directly out of Visual Studio to see where it’s failing?

- Ben