Dead servo controller?

I purchased one of your pre-assembled 16-servo controllers recently, and I’m having trouble getting it to work. None of my LEDs will light up.

The power supply I’m using for testing is a little wall adaptor that gives 6.6 volts. I’ve gone through the troubleshooting steps, and there doesn’t seem to be a short. The voltage I’m getting when I test C1 and C2 is 4.67 volts.

Does that mean the voltage regulator is the problem? Or is that enough of a difference from 5v to prevent it from working?

Any help would be appreciated…


We do full tests of all assembled units before we ship, so if there was no indication of damage through shipping, your servo controller probably works.

4.67 volts is definitely low, which leads me to suspect that you are not giving the board enough input voltage. Are you using the wall adapter to power the servos, too (because that generally doesn’t work)? Is the 6.6 V with no load, and what is the rated voltage on the adapter?

If possible, try connecting a battery to the logic supply and leaving the servo power disconnected, just to see if you get some LEDs to come on. A 9V battery or a 7.2 V RC car battery pack would do for the very quick test. If none of the LEDs still come on, it might be necessary for you to send the servo controller back to us for inspection. (If you do want to send it back, please contact us first for an RMA number.)

- Jan

I tried hooking up a 9V battery to the logic supply, with no servos attached and no serial connection. I haven’t tried hooking up the servo power supply at all yet. The battery is giving 8.6V while hooked up.

I’m getting the yellow LED to light, but that’s it. I now get no voltage at all across C1 or C2, but probing C1 with my meter flips yellow D3 off and green D2 on.

Any ideas on what this means?


The yellow LED coming on is normal; that’s what happens before any serial activity is detected (see page 10 for the initial test and all of the LED interpretations). What happens when you send some serial commands?

As for your C1 and C2 measurements, I suspect that you might be taking bad measurements. Are you sure you are not shorting anything as you take your measurement (you might have forgotten the leads in the current-measuring plugs)? If you are just taking voltage measurements, it shouldn’t affect the operation of the servo controller.

- Jan