Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

"Couldn't find a Board on the selected port" error with new Zumo 32U4


I just received my new Zumo 32U4 (pre-assembled version) today. I’m following the setup directions (at https://www.pololu.com/docs/0J63/all) to the letter. I’m on Windows 10 Pro.

Step 9 in section 5.2 (Programming using the Arduino IDE) says to specify the port using the Tools->Port menu in the Arduino IDE (version 1.8.2) , but the menu is grayed out!

Also, when I go to Device Manager, there is not section for “Ports (COM & LPT)”. This seems related.

The Arduino IDE has a text in the bottom right which says “Polulu A-Star 32U4 on COM1”, so I thought maybe it know the COM port and doesn’t let it be configured. So, I tried Uploading the Blink example anyways, but get the error: “Couldn’t find a Board on the selected port. Check that you have the correct port selected. If it is correct, try pressing the board’s reset button after initiating the upload.”

I did try the rest button on the Zumo 32U4 but that did not work.

At this point, I’m stuck. Based on the amount of people on the internet asking about (1) COM ports in the Device Manager, and (2) the Port menu disabled, I deduce this is a pretty common problem. Unfortunately, I can’t find a straight forward solution.

Help me, Obiwan, you’re my only hope.



Do any new devices show up in the Device Manager when you connect the board via USB? If not, can you try a different USB port? Do you have any other USB cables you can try? I suspect the one you are using might be a charging cable and not a data cable. Charging cables lack the necessary wires for USB communication, which are necessary for programming the Zumo 32U4 board from your computer.



Ahh, man, first off…thanks! Problem fixed.

I tried EVERYTHING. Second computer, every USB port, manually adding things, scouring the registry.

In the end…it was the USB cable. I never would’ve suspected it if you didn’t suggest it. Thanks again.

Mikey Wetzel