Controller don't work

Hey, I have new problem now. My controller seems
accept data well. Every time I send data green LED lights.
But servo doesn’t respond.

I check my servo and code and they ok.
I also check the servo number that servo controller
response to, it is correct too.

So, what may the reason cause this problem??


Are you powering your servos? In Mini SSC 2 mode, you should at least see all servos move to neutral once you send the first byte. Can you get that to happen?

- Jan

Yes, I have powered my servo. I can use now after I reset the servo controller.

Under pololu mode, can I wire my servos to the servo controller by only signal line? That is, I supply the servos with power, separately.

It seems that the power of servos can not be supplied
separately. If I wire only the signal line and send the data, servos have no response.

Thanks for the pictures, they always make things clearer. I see what might be the problem now (although I really should have caught it, you did mention this earlier).

In general, the Pololu serial devices, including the serial servo controllers, are meant to work with straight through type serial cables, as opposed to null modem cables, which have their transmit and receive lines are crossed. The servo controller is expecting to receive serial data on Pin 3, and your connection on that side of your custom cable is correct.

Assuming your ZigBee module (I don’t recognize the brand/model either) uses the standard DB9 serial port layout, it is outputting data on Pin 3, but your serial cable is connected to the serial port’s Pin 2, which is its receive pin.

Try modifying your cable to connect Pin 3 on the ZigBee module to Pin 3 on the servocontroller (leaving the Pin 5 to Pin 5 ground connection alone). If this was the whole problem I’m confused about how it worked at all in the first place though.


P.S. I hope you don’t mind (if you do let me know and I’ll take them down), but I wanted to post some of the pictures you sent me, your robot looks AWESOME:

Thanks Adam. I will check the connection again tomorrow.

I think my previous mention is not clear enough and confused

Simply speaking, there is two problem I encounterd:

In pololu mode with Zigbee, after few seconds or
minutes of normal operation (servos have normal
response), suddenly red led lights up and is needed to
re-power the controller. But in Mini SSC mode with
Zigbee, both the controller and servos work well.

I have tried to separate the power of servos from servo
controller (wire only signal lines of servos to
the servo controller) in pololu mode but in this case,
servos have no response.
Do you think that there is any posible solution for this

PS. I need to connect two controllers on the same
serial line since I only have two 8-servo controllers
and have 11 servos to be controlled and hence, pololu
mode is required. In my contury we need three weeks
to recive a 16 servo controller.

Darn! I was so sure it would be the easy fix.

You might as well try check if Pin 3 on your ZigBee module is a working serial output, but if it is working reliably for a while every time before getting messed up, then your serial connection is probably correct, and your ZigBee module just has a non-standard DB9 serial pinout. The ZigBee module might just be spitting out garbage occasionally. For a quick fix you could use the DTS/RTS reset feature to periodically reset the controller. I know, it’s lame.

When you separate the power sources from the servos and the servo controllers, the grounds of both the servos and the controller must still be connected, not just the signal line. Might that be the problem?

By the way, if you don’t mind using MiniSSC-II mode, you can change the servo numbers of one controller in Pololu mode, then use the different servo numbers in MiniSSC-II mode!


Are your grounds connected? You cannot have just one wire connecting from the servo controller to your servo. If you want external servo power, you need to connect that ground to the servo controller ground.

- Jan

OK!! thank you for your help guys. They need to be grounded together.


Do you mean that two servo controllers are connected to the same serial line and, one is in pololu mode and the other is in Mini SSC mode?

Or you mean that I set up their servo number in pololu mode and wire them up on the same serial line with Mini SSC mode ?

I saw this paragraph in manual

I though this implies that the servo controller can not on the same serial line in Mini SSC mode. Am I wrong?

Guys, I really appreciate your helps.

You are correct that the servo controllers that share a serial line must either all be in Pololu mode, or all be in MiniSSC-II mode. What I’m saying is that you can set one controller to a new set of servo numbers in Pololu mode, then restart it in MiniSSC-II mode and use it on the same serial line as your other controller (also in MiniSSC-II mode).

When you use the Pololu mode command to change the servo numbers one of your controllers responds to, it will also change the servo numbers the controller will respond to in MiniSSC-II Mode. These settings are saved, so when you restart your servo controller in MiniSSC-II mode, it will respond to a new set of servo numbers.


Great!! So I can use two servo controllers on the same serial line with Mini SSC mode. It’s a good news for me.

I though that to be used on the same serial line, servo controllers must be in pololu mode. This problem bothers me since my servos work only in Mini SSC mode.

Thank you for your information, Adam.