Channel on micro maestro stopped working

I have recently purchased the micro and it worked perfectly. I went to use it again after a month of not being used and realized that one of the channels isn’t working. I checked the settings compared to the other channels and its the same. I plugged another servo to that channel and it still doesn’t work. I’m assuming that it’s starting to go bad. Has anyone else had similar situation?


It sounds like you might have burned out that pin. Have you tried moving the servo in the Maestro Control Center using the sliders in the Status tab? Also, another way to test that pin is to configure it as an input, connect a pushbutton or switch to the pin, with the other side of the switch connected to the +5 (out) pin. In the Control Center, go to the Channel Settings tab, and change that pin’s Mode dropdown box to “Input”. It should now read the voltages from pin. More information can be found in the user’s guide in section 4.e.

Please let me know if this does not solve the issue, or if you have any additional questions.


Yes I did try using the slider on the control center and no luck. I swapped servos and still the same issue. I haven’t tried the push button, but it might be what you mentioned about the channel being fried.