Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Change target position range

#1

Hello,
I started using a Tic T825 stepper motor controller via USB on Windows PC.
I have a question with ticcmd when setting a target position.

How can I change the range of target position setting?
When I run the command below:
ticcmd --exit-safe-start --position 400
I just get the position of 200.

The default setting of the target position range is from -200 to 200.
Although it can be changed using the Tic Control Center (but I cannot save the new range), I’d like to do the same thing using ticcmd.

Unfortunately I couldn’t find a command to change the range in the User’s Guide.
Could you please let me know how to do it?

Regards,
bib

#2

The values shown on either side of the slider in the Tic Control Center are only related to the limits for the slider in the software. Using the ticcmd --position command, you should be able to specify a position value between −2,147,483,648 and +2,147,483,647 as listed in the Command reference section of the user’s guide.

Are you in 1/2 step microstepping mode? Note that the units for the Set target position command is microsteps. For example, if you use a 200 steps per revolution stepper motor, a position of 200 in full-step mode is 1 rotation, but in half-step mode it is only half a rotation (since it would be 200 half steps).

If you continue having problems, can you post your Tic settings file as well as the exact ticcmd commands you are sending? You can save your Tic settings file by selecting the “Save settings file…” option within the “File” drop-down menu of the Tic Control Center while your controller is connected.

Brandon

#3

Hi Brandon,

Thank you for your advice, and sorry for my late reply.

Ok. So the limit values for the slider are just used in the Tic Control Center.
But unfortunately, I still cannot get the position of more than 200…

Yes, I’m in 1/8 step microstepping mode; this means that my stepper motor moves 1 rotation with 1600 steps, is this right?
I send the command below for 1 rotation, but the motor just rotates 1/8 rotation:
ticcmd --resume --position 1600

My Tic setting file is as follows:

– setting file –

# Pololu Tic USB Stepper Controller settings file.
# https://www.pololu.com/docs/0J71
product: T825
control_mode: serial
never_sleep: false
disable_safe_start: false
ignore_err_line_high: false
auto_clear_driver_error: true
soft_error_response: decel_to_hold
soft_error_position: 0
serial_baud_rate: 9600
serial_device_number: 14
serial_alt_device_number: 0
serial_enable_alt_device_number: false
serial_14bit_device_number: false
command_timeout: 1000
serial_crc_for_commands: false
serial_crc_for_responses: false
serial_7bit_responses: false
serial_response_delay: 0
vin_calibration: 0
input_averaging_enabled: true
input_hysteresis: 0
input_scaling_degree: linear
input_invert: false
input_min: 0
input_neutral_min: 2015
input_neutral_max: 2080
input_max: 4095
output_min: -200
output_max: 200
encoder_prescaler: 1
encoder_postscaler: 1
encoder_unlimited: false
scl_config: default
sda_config: default
tx_config: default
rx_config: default
rc_config: default
current_limit: 480
current_limit_during_error: -1
step_mode: 8
decay_mode: mixed
max_speed: 1600000
starting_speed: 0
max_accel: 40000
max_decel: 0
auto_homing: false
auto_homing_forward: false
homing_speed_towards: 1000000
homing_speed_away: 500000
invert_motor_direction: false

Thanks in advance,
Bib

#4

Thank you for your settings file.

When you send your ticcmd --resume --position 1600 command, does the red LED on the Tic turn on when the motor stops? It looks like you have the “Command timeout” enabled and set to 1 second (which is the default setting). This means if the Tic does not receive another command within 1 second, it will trigger the “Command timeout” error and stop the motor. To avoid this situation, you can either run ticcmd --reset-command-timeout every second, or disable the command timeout feature by unchecking the “Enable command timeout” option in the “Input and motor settings” tab of the Tic Control Center.

Brandon

#5

Hi Brandon,

Thank you for your helpful advice. It works!

Yes, the problem was the “Command timeout”.
After unchecking the “Enable command timeout” in the Tic Control Center, I could get 1 rotation by sending “ticcmd --resume --position 1600” at my SP motor.

Again, thanks for you kind help.
Bib

1 Like