Castle Creation Phoenix 25

I am trying to use the Pololu Micro Serial Servo Controller to run 4 Castle Creation Phoenix 25 ESCs. I have run into a problem that I can’t figure out. I have not been able to get the ESC’s to initialize when I plug them into the Pololu board. They normally send out a chime when the are armed and I haven’t been able to get that to happen. I have the servo pins on the pololu board powered to 5V and I have the pololu board powered to 12 V. I have also tried to run the example code to send serial commands to the pololou board but it hasn’t changed the result. The speed controllers still won’t intialize. Any help would be appreciated.

Looking at the Phoenix 25 datasheet:

So to get your ESC to arm, you’re going to need to send a sufficiently low position command to whatever servo channel it’s plugged in to on your micro serial servo controller (lets call it the uSSC). After being powered on, the uSSC doesn’t send out servo signals until it has received a serial position command. In Pololu mode it will only start generating a signal on a channel once it has received a position command for that channel. In MiniSSC-II mode (with the blue jumper on) once you send one serial position command all channels will start sending signals, but the default signal corresponds to the neutral position, which probably isn’t low enough to arm your ESC.

What are you using to generate the control commands for your uSSC? Can you confirm that it’s actually doing what you want it to by plugging in a regular servo?

By the way, when you say you have the servo pins powered at 5V, are you using a separate battery or the BEC power from the Phoenix 25? I just wanted to make sure you’re not doing both at the same time. Actually, when you’re not powering other devices (i.e. servos) from the uSSC, you don’t need to worry about powering these pins, just the 12V to the servo controller VIN side will be fine.

So, any luck?



Thanks for your help. I am still having the same problem, however. I have plugged the uSSC into a standard servo and it works fine. I am planning on sending signals to the uSSC from a Gumstix processor running on a Console-VX expansion board. I am designing an autopilot for autonomous quadrotors. We built some last semester at my university using another autopilot that we had built and we wanted to make some changes to it.
I was wondering if you had any ideas as to how I can send a brake command to the ESCs? Or if you had any other ideas as to what the problem may be?
Thanks again,

Yeah! Never mind I got it up and working. I just hadn’t tried a low enough initial command. It works great! Thanks.


I would love to know more about your autonomous quadrotor project, but I should first ask if you have a website before I shower you with more specific questions.

I’m really interested because I just finished a masters degree, and my research project for the past two years has been trying to fly a Draganflyer V TI indoors with an ordinary desktop computer and under $500 of additional sensors/electronics. I got it to fly in four degrees of freedom on a test stand (limited to move at a fixed height around the circumference of a horizontal circle), but never completely free. I know a bunch of university groups have had great results using off-board processing and Vicon motion capture systems, but those are ridiculously out of our price range. I would love to see someone get one flying with more on board.