Can't install serial driver

Hello guys,

today I wanted to install the Maestro Control Center on my netbook (asus eee pc 900a) with windows xp home edition 32bit.
All worked great except the TTL Port, windows doesn’t find the drivers. The Command Port was installed correct.

So I have the problem, that I can use the Control Center (servos are moving correct) but not the serial Port. My little Java program, which works great on my laptop with the same servo controller, gets a weird error (no parameters).

I reinstalled it about 5 times, but nothing happend.

best regards

What Windows XP Service Pack level do you have on your netbook (asus eee pc 900a)? Is it Service Pack 2 or Service Pack 3?



it is Sp2. But I can’t upgrade it to sp3, it’s no suggested by asus.

Here is what we wrote in the Maestro user’s guide about SP2:

So you could try installing Hotfix KB918365 from Microsoft and that might fix your problem.

I’m curious, is Asus specifically telling you not to upgrade to SP3, or are they just not mentioning it at all? Does Asus give a specific reason why you shouldn’t upgrade your computer?


I installed the hotfix and now the TTL Port is shown as correct installed in the device manager.
But it doesn’t work in my program. I get this Error:
“Error 0x57 at …\src\termios.c(1310): Wrong parameter.”

Asus suggested sp2, because it should be faster. Some other guys with that netbook say the same.

This new error is not unexpected. As I said, the hotfix doesn’t work for everyone.

One thing you could try is copying the newer version of usbser.sys from one of your computers with Service Pack 3 and putting it on your ASUS netbook. Beware: this is a risky thing to do and it might cause your system to crash and/or fail to boot. You should save a copy of the old usbser.sys and be prepared to restore it if something goes wrong, and take any other precautions you can think of. If you choose to do this, let us know how it works for you.

A less risky solution would be to get a USB-to-TTL serial adapter that works with Windows XP SP2 and use that to connect the computer’s USB port to the Maestro’s RX and TX lines.

Unfortunately I don’t have any better ideas for you.


I have now installed sp3 because I don’t want to take a risky soluation. I have enough trouble with that netbook :laughing:
It works now, but through sp3 the hard drive is nearly full and it got slower.