Cant get a USB 16 channel board to work

Ive tried to use the code below, and have even corrected the errors in their code (it doesnt tell MSComm1 which port to use on port opening)

When first connecting the board I have a green and amber light, and when first sending a command the amber light is replaced by a constant green.

Each time I send a command I get a short flashing greenlight.

However, Im getting no motion at the servos

OK, I feel kinda silly now, just tried something and now it all works

The problem was, when I read the manual I distictively read the bit that said

‘Power for the board is supplied by the USB connection, so no additional power needs to be connected’

At that point I though cool, yet completely failed to read the next 5 words

‘…except for the servo supply’

What didnt help was the power supply riser being sent separate to the board, which to me highlighted the optional ness of an external power supply!!


Good to hear you got things working. The terminal block is optional since you can power the servos from one of the 16 servo connections. Most RC receiver packs have connectors that are the same shape as the servo connectors, so they plug right in. Others might want to solder in wires instead of the terminal blocks, so we include the terminal block as an option for the user.

- Jan

I checked out the tutorial, but didn’t know how to correct the code to indicate which port is the MSComm1. Can someone elaborate on this point.