Can't get 18v7 Motor Controller to power on anymore

Hello! I’ve been using the 18v7 motor controller for a month or so now on a robotics project. I’ve been powering it using a 9v battery and controlling a small brushed DC motor and it has been working just fine up until last night. When I’m not using it I store it in an antistatic bag. Last night when I attempted to power it on, none of the normal power LEDs light up and the board eventually got hot in the center. The same thing happens if I attempt to connect it to my computer (and others) via USB. I am a beginner in this but I’m not really sure what I’ve done wrong.

If anyone can offer advice, maybe a component that needs to be replaced, I would appreciate the help.



Have you tried any other power supplies? When you connected the board to USB, did you have anything else connected? Is there one specific component that gets hot? Can you post pictures of both sides of your board?


I didn’t have anything else connected when I have it plugged into USB. I’ve tried multiple cables/power sources. I would say the connector or the middle of the board where there is a minus gets hot when I plug it in. Attached are pictures

It sounds like the motor controller is probably damaged and it usually does not make sense to try to fix them. How did you have everything connected when you first noticed it wasn’t working? Did you change anything right before it stopped?

By the way, the pink bags we have used to ship products (and similar pink static bags in general) are static dissipative and offer some static protection, however, it is still possible for electronics inside them to be damaged by direct ESD from other sources.

If you email us with your order information and reference this thread, I can look into helping you with a discount on a replacement board.