Can't connect Micro Maestro - USB device not recognised

I’ve got a Micro Maestro 6, and I’m having trouble getting to first base.
I’ve installed the Maestro Control Center.
I’ve connected it to my Win XP SP 3 Asus Eee netbook. The yellow indicator led flashes twice, so something is working. (therefore the board is not completely dead, and the cable must be OK)
Windows then comes up with ‘USB device not recognised’. Reboot doesn’t help :frowning:.
The web page mentions ‘usbser.sys’, which my laptop just doesn’t have.

So I tried connecting it to my WinXP SP3 desktop - same problem.
I also tried my Win7 32 and Win7 64 machines, both of which have the identical behaviour.

I’m not sure what to try next. Any suggestions welcome.



Solution found! If it’s not the device, and I’ve ruled out the computer, then it must be … the cable!
Tried a different cable, and it’s now installing.
I’ve left this topic in here, in case someone else searches ‘device not recognised’.
Looking forward to getting it doing something now!

Hello, Peter. I’m glad you were able to solve your problem.

Does your Windows use British English spelling? :slight_smile:


Yes, I’m in Australia and use Australian-English spelling.