Cannot connect to Maestro Control Center


I’m re-purposing a micro maestro 6 servo controller from a piece of artwork it was previously used in and trying to do something new with it. However, when I try to connect it to the Maestro Control Center on my computer, I get the following errors:

“There was an error getting the firmware version of this device. Control transfer failed. Error code 0x79.”


"Error loading settings from this device. There was an error getting parameter PARAMETER_SERIAL_MODE from this device. Control transfer failed. Error code 0x79.

The last time I used this device it was attached to an ultrasonic range finder and a servo, it operated the servo behavior based on the reading from the range finder and last time I did that, it was working just fine. I’ve tried to reset the device defaults in the control center but I got a very lengthy error from that.

Any ideas?


Hello, Tim.

I am sorry you are having trouble with your Maestro. That error code is new to me so I looked it up and found out that it means “The semaphore timeout period has expired.” Unfortunately that doesn’t help much. What version of the Maestro Control Center do you have? What operating system are you using? Could you try using a different USB cable and also try using a different computer?


I’m using Pololu Maestro Control Center version and Vista 64 for my operating system. I could try different USB cables or different ports, but not a different computer unfortunately. I’ll post here if it works.


Okay. Please let us know what your results are.


Ok, the board connected just like it is supposed to when I tried a different USB port on my computer. It did not, however, operate a servo through the control panel as it should have. Not sure if it’s the board the port or the servo.


I am glad you are making progress. What are you using to power the servo? What serial mode is your Maestro set to? You can see that in the Serial Settings tab. What buttons did you click in the Maestro Control Center when you tried to operate a servo? When you did that, what did you expect to happen and how is that different from what actually happened?