Burned out A4983 using 10V stepper motor. How?

Howdy, this is my first attempt at microcontrolling, and of course I burned up the A4983 chip :frowning:

I have a Arduino Duemilanove, and I’d like to use it to control a 10V bipolar stepper (#1208) via the A4983 stepper driver (#1201). Attached is my wiring setup.

At first I wanted to just make the stepper move, so I wrote this program:

int steppin = 9;
int dirpin = 8;

void setup() {
  pinMode(steppin, OUTPUT);
  pinMode(dirpin, OUTPUT);
  digitalWrite(dirpin, HIGH);
  digitalWrite(steppin, LOW);

void loop() {
  digitalWrite(steppin, HIGH);
  digitalWrite(steppin, LOW);

Then, when I plugged in the 10V power, the A4983 chip popped and smoked. I’ve attached a picture of wasted chip with two burn holes.

So what did I do wrong?
Could it be the program isn’t sending the correct instructions to the chip?
Is all the wiring correct?
Does it have something to do with current? The 10V motor has a current rating of 500mA, and the A4983 has a rating of 2A, so I thought that was ok.
Is there some sort of current limit I can put on the driver? How do I do that? I saw this, but I’m not sure how to wire/set it up.

I’ll be ordering another board and trying again. Any ideas on how to make this work?


That’s strange and unfortunate. Your code shouldn’t cause this kind of problem. There definitely is current limiting available, and you need to set it correctly to get microstepping working. We talk about it on the product page and there is a detailed discussion of it in the datasheet. However, that should not have caused your problem since the motor you’re using just doesn’t draw that much. What is your power source? Can you provide more details about the timing of the failure?

- Jan


This should not cause the failure you describe, but your wiring schematic shows MS1 floating. We have a simple wiring example on the product page.

- Ryan

My power source is a compact switching power supply (Velleman PSSMV7U) with the setting at 10V. My multimeter reads it as 10.13V and the arduino power supply as 4.91V.

I originally ordered two A4983 drivers, so I soldered the other one and stuck it in the circuit without the stepper motor, dir, step wires (diagram (2) attached). I added the jumper to the MS1 and MS2 pins like you suggested. I noticed that the A4983 chip would get extremely hot when I attached both the 10V and the 5V supplies. It would not get hot if only the 10V or the 5V were attached. Is this normal? I thought it was only supposed to get hot when it was actually driving the motor? Is this an indication of a short somewhere?

Then, I removed the jumper for the RES and SLP pins (diagram (3) attached). The chip would no longer get hot even with both 10V and 5V supplies attached. Is this normal? There is a ~4.5V potential between those two pins.


I tried reproducing your setup, and I did not get the same result. The board drew 10 mA from the 5V supply, nothing form the 10V supply, and it did not get hot. Can you post a photograph of your setup?

- Ryan

Sure, here’s two pictures of my setup. The RES-SLP jumper is in place. The A4983 chip gets really hot when I plug in the Arduino and 10V power supply.

That looks okay, so I’m afraid you’ve damaged the second board, too. Is it possible you accidently connected power backwards at some point? Do you have access to an oscilloscope to look at you power supply output? You could also check your soldering. Your first picture is a bit blurry, but the soldering looks pretty bad. You should check for shorts and also make sure that all the pins are actually soldered to the pads well.

- Jan

Yeah, I figured the board was shorted out somehow. The soldering iron I used was a bit fat, so the soldering was pretty sloppy, but I can’t see any shorts that are obvious. I’m going to use a smaller iron tip to solder the next boards when they come. Will update when I get them in.

Which power supply needs to be backwards to cause a chip failure? I don’t think I ever got the 10V or the 5V backwards, but maybe I tapped the 5V wire to the wrong pin when I was setting it up. Would a -5V cause the failure?

EDIT: I don’t have an oscilloscope, but I do have a multimeter.

Reversed power is a good way to break just about any chip. Reversing either of the supplies on the stepper motor driver will likely destroy it almost instantly. It sounds like you might have been adding your wiring while power was applied, which is generally not a good practice.

The reason I was asking for the oscilloscope was to look for transients that you would not see on a meter. However, if you think you might have connected power backwards at some point, that is much more likely to be the problem than your power supply. You might still look at this article about LC spikes just so you’re more aware about what might be going on that your meter won’t show you.

- Jan

I got my new A4983 driver in today, and I carefully soldered it up. I wired up the breadboard and voila! The program worked great. The A4983 chip did not heat up ever, even when driving the stepper. Thanks very much guys! I think it was probably a reversed supply that did me in the first time :blush:

I have another question about the drivers, but I’ll post that in a new topic.

Yay, congratulations on your persistence and success. I am happy any time a customer comes away from a broken part without blaming us, but it’s extra good to hear about things eventually working.

- Jan