A4988 Stepper drivers

I have a problem with my stepper motors randomly jittering around without any input from the controller.

I have connected my three A4988 stepper motor drivers to my motors (which are Pololu 3.9V 600mA bipolar ones). I successfully got two of the three motors turning as instructed by Arduino control, but the third did not work (no voltage/current was being output to the motor wires). I noticed that the sleep/reset pins were at 1.3V instead of 5V, so I connected them to the 5V line. At this point the other two motors started stepping seemingly randomly. Powering the board off and on again did nothing to fix this, nor did removing the 5V pin connection I had made. The third motor remained still, with no voltage appearing at any of its wires.

I’d be grateful for any information which might help me fix this problem!


Could you post a picture or diagram of your setup showing the connections you have made to the drivers?

- Kevin

Sure - will do it as soon as I get into the lab tomorrow morning.


Hi Kevin,

I’ve attached photos of the front and back of my circuit. This morning I took the drivers off one board and put them onto three separate ones in an attempt to eliminate any interaction between them.

When I ground the step and direction pins, the motors don’t move and there is a resistance when I turn the motor shafts by hand (which is as expected).


What are you doing with the step and direction pins when you experience the problem in your first post? That behavior could be explained if you ever leave those lines floating; if you have them connected to your Arduino, you should make sure the Arduino is always driving them either high or low (or add pull-up or pull-down resistors so that they are in a well-defined state even if the Arduino is not driving them).

I am not sure why you see 1.3 V on the [o]SLEEP[/o] and [o]RESET[/o] lines; do you only see this happening with one of the drivers?

Also, have you considered using some female headers instead of soldering the drivers directly to your stripboard? This would make it easier to swap in different drivers when you want to test or replace them.

- Kevin

Sorry about the size of the images - forgot to resize before uploading!

I think I have solved the problem of the jittering. I am using the 5V output from the Arduino to power the drivers now, but still using my hacked ATX power supply for the 12V on the motors. I guess the regulator on the ATX power supply is either rubbish or damaged.

The 1.3V on the SLEEP and RESET lines is indeed only on one driver, so that one must be faulty. I will attempt to return it to the UK distributor I bought it from.

Good idea on the female headers - I’ll get some of those for sure. Many thanks for your help Kevin.

I am glad to hear you found a solution. I assume the faulty driver still doesn’t work, even if you try to pull those lines high?

If you can’t work out a return with your distributor, you can contact us via email and we can see about at least offering you a discount on a replacement driver.

- Kevin