24 channel Servo controller disconnects after time

I use a Pololu 24 channel servo controller in a scientific research project. It works great! For this project the servo controller works about once every 3 hours for a few seconds to control a few valves (with standard servos). The controller is hooked up to USB and has an external 5v source
This system works good in general but sometimes (seems to be after 6-10 days or so) the controller powers down? (no LED lights!) and the virtual COM port dissappears. When the servo controller doesn’t work, the $100K machines don’t work and i don’t get data.
Other USB devices do still work when the Pololu servo controller stops.

is there any known issue that could cause this?

thanks a lot!

Hello, Frank.

I am sorry that you are having trouble with the Maestro. When you say that the virtual COM port disappears, does that mean that it is no longer visible in your Device Manager? When you say that the controller powers down, what indications make you think so?

The next time it happens, please let me know:

  • What entries for the Maestro are still visible in your Device Manager?
  • What are the Maestro’s three LEDs doing?
  • If you temporarily short the Maestro’s RST pin to the GND pin, does that solve the problem?
  • If not, does unplugging and replugging the USB cable solve the problem?

We have encountered this general type of problem before, but we do not have a great idea of what causes it or how to solve it. Our best idea is that there is some kind of electrical noise that is getting caused by something in the system, and the USB port is shutting down in order to protect itself from damage.

Sometimes the USB host will just stop sending packets on the USB data lines, which tells the Maestro that it should go into USB suspend mode and conserve power. You can see if this has happened by probing either the D+ or D- line with an oscilloscope, and seeing if there is a digital signal there. There should be at least one packet per millisecond under normal operation. There is an option to make the Maestro ignore USB suspend in the configuration utility, and you could try enabling it, but that won’t actually fix the underlying problem that caused the USB data to shut off.

Sometimes the USB host will shut off power to the USB VBUS line as well. You can probe the pins of the USB connector with a multimeter to see if this has happened.

In one case the problem was solved by changing to a better power supply. Could you describe how everything is connected to the Maestro, and what kind of power supply you are using? Some pictures might help too.


Thanks for your reply,
of course it will probably take a few days before it happens again, but here the answers i have now

No, idea. My python script crashes with the error that the pololu command com-port does not exist.

As far as i can remember from the last times they are all off. (maybe except the red one)

No idea, will try this next time

Yes i tried this and it works. Restarting the computer also works.

The power supply i use is a 6.5V 2A wall-thing. It is a UL listed one.

I am wondering if the problem might be caused by ground voltage differences? The power supply of the servos is plugged into a UPS, the laptop is not. any idea on this?

Thank you!

I do not think that is likely to be the problem. Let me know when it happens again and you have more information.