18v15 dead after Apply Settings

One of my brand new 18v15’s was working ok while I was setting it up and tweaking some of the motor settings last night. The last time I changed something (I think it was brake duration) and pressed Apply Settings in Simple Motor Control Center it went dead. The power indicator lights went out and it disappeared from Control Center as a device. I unhooked everything, checked connections, and tried hooking it back up. Status and error lights do not come on. The green USB indicator light comes on but the controller no longer shows up as a USB device. I’ve tried other USB ports and another laptop.

It was set up for single channel RC control, hooked into a 3C lipo battery putting out right at 11.5v at the time. The motor was stopped, and the ammeter showed the total load (for the whole bot, with another idle controller and a receiver) at the time to be around 200mA. This controller had the BEC disabled, while the other controller was enabled at 5V.

I saved the settings file right before trying to apply the update, and it is attached.

Any thoughts? I really like these controllers and this is the first issue I’ve had with any of them, but the first time I’ve ussed the 18v15’s. I’ve been using the 24v23’s on my larger bot for several weeks now.
right.txt (2.97 KB)

Hello, RFarmer.

I’m sorry you are having trouble with one of the 18v15 controllers.

How does the green USB LED behave when you connect the controller to USB? Does it blink or is it just on solid? How does it blink?

Maybe the controller is in bootloader mode. Do you see any entry for it in the Device Manager? Do you see any entry for it in the dropdown box of the Firmware Upgrade window (Simple Motor Control Center -> Device -> Upgrade Firmware…)?

Does the board get hot when it is connected to USB? Please be very careful not to burn yourself.


It gets warm, and approaches hot. I unplugged it before hot.

LED light is solid green, no flashes.

Nothing showing up in the device driver list.

Also I’ve just discovered that the LED status light only comes on when the controller is externally powered, unlike the one that is still working.

I’m off to solder up the spare.


The second of the originals is still working as-is, but the USB light no longer lights up and it isn’t seen by my PC’s, so I’m stuck with the settings it currently has, which aren’t right yet.

The first spare, the USB status doesn’t light up at all, so I cannot configure it. Upon further inspection I discover it has a missing surface mount component (the large square one next to the negative capacitor through hole) right out of the bag.

The second spare seems ok (I sure am glad I ordered 4 of these things) so far, but is pretty useless to me by itself, and I’ve yet to try to change the settings. The first two worked on until I ran a few settings through them.

I think I got a bad batch. I can’t trust these things to go into a competition with. Very dissapointed. :frowning:

Unfortunately, for your first original, the one that is heating up, I won’t be able to help you further without seeing the board myself.

For your second original there is still some hope. First of all, you tried connecting it to multiple PCs, to rule out a problem with the PC, right? Do you remember what you were doing with it right before it stopped working? Maybe the firmware on the controller is corrupted but the bootloader is still there. Could you please try this procedure to get it into bootloader mode?

  1. With everything disconnected from the controller, use a screwdriver or other conductive tool to short together the controller’s bootloader pads, which are two exposed pieces of metal that are indicated in this picture:
  2. While shorting the pads together, connect the controller to USB.
  3. If this is done successfully, the controller should be in bootloader mode and its green LED should be doing a double-blinking pattern, and it should show up in your computer’s Device Manager. You can stop shorting the pads together now.

For your first spare, I’m not sure which surface mount component you are referring to, so it is possible that it is one of the components that were intentionally left off of the board. Could you send us a picture of the board to indicate which component you are referring to?

I am sorry you are having so much trouble with these controllers. We test each unit before shipping them, so it is worth investigating whether there is something in your setup that is causing problems. Could you give a more complete description of the wiring to your RC receiver, 3C lipo battery, and motor? Pictures of your setup and links to product websites would be useful too.